Home » Developer & Programmer » Reports & Discoverer » Report Builder crash (Developer 10g, Windows XP)
Report Builder crash [message #634561] Wed, 11 March 2015 06:03 Go to next message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
Hi,

hope everybody is fine.

My problem is when i run report in report builder, it crashes while formatting pages.
Report query is working fine in toad.

Regards
Athar
Re: Report Builder crash [message #634562 is a reply to message #634561] Wed, 11 March 2015 06:08 Go to previous messageGo to next message
Littlefoot
Messages: 21576
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
  • What does "crash" mean? Do you ever get any error message? If so, which one? Or does it just terminate Reports builder?
  • When does it crash? How many pages does it create before crashing?
  • Saying that it works fine in TOAD: how many rows does query return? TOAD restricts that number to 500 by default. How many rows does it *really* return? What happens when you do that in TOAD?
Re: Report Builder crash [message #634566 is a reply to message #634562] Wed, 11 March 2015 06:42 Go to previous messageGo to next message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
Report builder exits with unexpected error.

but somehow report starts executing successfully now.

thanks.
Re: Report Builder crash [message #634568 is a reply to message #634566] Wed, 11 March 2015 06:48 Go to previous messageGo to next message
Littlefoot
Messages: 21576
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Did you "now" use the same parameters as "before"? Maybe the error cause didn't automagically disappear - maybe you just avoided it using different parameters.
Re: Report Builder crash [message #634572 is a reply to message #634568] Wed, 11 March 2015 08:07 Go to previous messageGo to next message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
i used exactly the same parameters. i wonder whats happening.
Re: Report Builder crash [message #634580 is a reply to message #634572] Wed, 11 March 2015 10:54 Go to previous messageGo to next message
Littlefoot
Messages: 21576
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Well, who knows ... if the error happens again, provide as many details as possible (screenshot is welcome).
Re: Report Builder crash [message #634612 is a reply to message #634580] Thu, 12 March 2015 02:06 Go to previous messageGo to next message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
Please reconsider the issue. now problem occurred while formatting page 2.

screenshot is attached.

/forum/fa/12540/0/
  • Attachment: rep-error.JPG
    (Size: 71.67KB, Downloaded 608 times)
Re: Report Builder crash [message #634614 is a reply to message #634612] Thu, 12 March 2015 02:57 Go to previous messageGo to next message
Littlefoot
Messages: 21576
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I just hate Reports, I really do. It is the worst (unstable) of all Oracle products I've ever used.

Unfortunately, I can't tell what might be wrong just by looking at the screenshot. Even if you opened "Click here" link in the error window, I probably wouldn't be able to interpret it. As the report - with the same parameters - sometimes work and sometimes does not, it looks as a mystery which I can not solve. Sorry.
Re: Report Builder crash [message #634635 is a reply to message #634614] Thu, 12 March 2015 06:02 Go to previous messageGo to next message
athar.fitfd@hotmail.com
Messages: 193
Registered: October 2007
Location: pakistan
Senior Member
anybody else have any idea?
Re: Report Builder crash [message #634674 is a reply to message #634635] Fri, 13 March 2015 01:10 Go to previous message
Littlefoot
Messages: 21576
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Just one (which probably won't help): did you try to recompile the report (Ctrl + Shift + K)?
Previous Topic: Oracle Report generated as a PDF with editable fields
Next Topic: rwserver problem
Goto Forum:
  


Current Time: Tue Jul 14 15:30:40 CDT 2020