Home » SQL & PL/SQL » Client Tools » Packages in TOAD
Packages in TOAD [message #158711] Tue, 14 February 2006 00:20 Go to next message
Brayan
Messages: 315
Registered: June 2002
Senior Member
Hi All,

I'm using Toad as PL/SQL Editor. While compiling it shows the package as INVALID eventhough it is VALID. But it is not true for all Packages i.e for some packages it shows the actual status and the error messages also if exists.

Does anybody has any solution

Ronald.
Re: Packages in TOAD [message #158718 is a reply to message #158711] Tue, 14 February 2006 01:21 Go to previous messageGo to next message
vban2000
Messages: 207
Registered: March 2005
Senior Member
Hi Ronald

Try the following in the SQL*Plus and see if any errors..

ALTER PACKAGE package_name COMPILE DEBUG;

SHOW ERROR


regards
AnDy
Re: Packages in TOAD [message #158720 is a reply to message #158718] Tue, 14 February 2006 01:33 Go to previous messageGo to next message
Brayan
Messages: 315
Registered: June 2002
Senior Member
Andy,

Sorry, May be my statement is not clear to you. I dont have problem in compiling a package. But, in TOAD eventhough it is valid after compiling, the status in TOAD shows that it it INVALID(Toad staus in Status bar). But the status in user_objects is valid.

I'm asking is toad is not able to capture the status of DB or there are some settings we have to do!!

Ronald.
Re: Packages in TOAD [message #158723 is a reply to message #158711] Tue, 14 February 2006 01:41 Go to previous message
vban2000
Messages: 207
Registered: March 2005
Senior Member
Hi ...

My Toad (Ver 8.5.3.2) works fine - it shows valid status all the time.

Could it be a BUG in Toad?? maybe you can check this at theier webiste or send in a questino for it...

Regards
AnDy

Previous Topic: Required detail about isqlplus login id for Dba in oracle 10g
Next Topic: changing Sqlplus font
Goto Forum:
  


Current Time: Wed Aug 05 19:38:47 CDT 2020